Livestorm Marketing Website is currently unavailable

Incident Report for Livestorm

Resolved

The marketing website has been restored and is operating normally. We will continue monitoring the situation to ensure continued stability. We apologize for any inconvenience this may have caused.
Posted Jan 28, 2026 - 10:35 CET

Identified

Our team is rolling back the latest release and applying a fix, our marketing website will be back soon
Posted Jan 28, 2026 - 10:31 CET

Investigating

We have identified an issue affecting our marketing website (https://livestorm.co/
), which is currently unavailable. Please note that the Livestorm application (https://app.livestorm.co/
) remains fully operational and is not impacted.

Our team is actively working on resolving this issue and will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Jan 28, 2026 - 10:29 CET