Degraded Performance Related to Session Roles & Permissions

Incident Report for Livestorm

Resolved

The issue has now been fully resolved with a permanent fix. Event creation and role assignments are functioning normally. The situation is stable, and users can successfully manage session roles while participants are able to join their sessions without any issues.

Thank you for your patience, and we apologize for any inconvenience this may have caused.
Posted Feb 03, 2026 - 14:53 CET

Update

We are continuing to monitor for any further issues.
Posted Feb 03, 2026 - 13:54 CET

Update

Managing roles during event creation has been resolved. We will continue to monitor the system to ensure complete stability.
Posted Feb 03, 2026 - 13:53 CET

Monitoring

The issues affecting users’ ability to join events have been stabilized. This was caused by a temporary spike in activity impacting the Session Roles service.

The performance issue related to managing roles during event creation remains under investigation, and we are currently deploying a fix to resolve it.
Posted Feb 03, 2026 - 13:07 CET

Identified

We’ve identified that the degraded performance only occurs when managing session roles at the same time as event creation.
Managing or updating session roles after the event has been created is not impacted and works as expected.
Posted Feb 03, 2026 - 12:14 CET

Investigating

Following the rollout of the new session roles & permissions feature, we’ve identified degraded performance across parts of the platform.
Some users may experience slow loading times, delays, or intermittent errors when managing or interacting with session roles and permissions.
Our engineering team is actively investigating the root cause and working on mitigations to stabilize performance.
Posted Feb 03, 2026 - 11:53 CET
This incident affected: Livestorm app.