Observed latency on the platform

Incident Report for Livestorm

Resolved

Following our monitoring over the past few minutes, we can confirm that there is no longer any ongoing impact related to this issue. Users should now be able to access the platform and its features as expected.

We sincerely apologize for any inconvenience caused and appreciate your patience while we worked to resolve this.
Posted May 18, 2026 - 15:48 CEST

Monitoring

Our team was successfully able to mitigate the issue and the platform is now accessible as required.

We're continuing to monitor the issue to ensure that users have no further impact in regards to this. We apologize for any inconvenience caused to this end.
Posted May 18, 2026 - 15:33 CEST

Investigating

Our team has identified an ongoing issue where the platform is experiencing higher-than-usual loading times.

At the moment, the Events list page may fail to load, and event creation may intermittently fail. Some users may also experience slow or unresponsive pages.

We are actively investigating the root cause and rolling out fixes. We will share another update as soon as more information becomes available.
Posted May 18, 2026 - 15:16 CEST
This incident affected: Livestorm app.