Login with Google or Microsoft SSO is currently failing

Incident Report for Livestorm

Resolved

The issue affecting Google and Microsoft SSO login has been resolved following the rollback.

We have confirmed that SSO authentication is functioning as expected.
Posted May 19, 2026 - 10:28 CEST

Monitoring

The rollback has been completed, and SSO login via Google and Microsoft is now functioning as expected.

We are continuing to monitor the situation closely to ensure the issue is fully resolved.
Posted May 19, 2026 - 10:27 CEST

Identified

We have identified the cause of the issue: recent changes made to strengthen reCAPTCHA security introduced an unintended side effect that disrupted SSO login.

We are rolling back these changes and continuing to monitor the situation closely.
Posted May 19, 2026 - 10:23 CEST

Investigating

We have identified an issue causing login attempts via Google SSO and Microsoft SSO to fail silently.

Our team is actively investigating the root cause and working to mitigate the issue as quickly as possible.
Posted May 19, 2026 - 10:15 CEST