Events List degraded

Incident Report for Livestorm

Resolved

The issue affecting the Events list for a subset of users has been resolved and the service is now operating normally.

Our team will continue monitoring the situation to ensure everything remains stable.
Posted Mar 09, 2026 - 12:00 CET

Update

We are continuing to investigate this issue.
Posted Mar 09, 2026 - 11:48 CET

Update

Resolved – Events List Degraded

The issue causing the Events list to fail to load for a subset of users has been resolved. We rolled back a recent change which has restored normal service.

We are continuing to investigate the root cause and will take steps to prevent recurrence. If you are still experiencing issues, please contact our support team.
Posted Mar 09, 2026 - 11:42 CET

Investigating

We are investigating an issue affecting a subset of users where the Events list fails to load. Not all users are impacted.

We are actively investigating the root cause. No action is needed on your end.

We will provide an update as soon as we have more information.
Posted Mar 09, 2026 - 11:31 CET
This incident affected: Livestorm app.