Session list has latency in some cases

Incident Report for Livestorm

Resolved

The incident has been resolved. The root cause has been identified and we took measures to fix it.
Posted Jul 09, 2026 - 19:41 CEST

Investigating

We are currently investigating this issue.
Posted Jul 09, 2026 - 18:41 CEST
This incident affected: Livestorm app.